Customer Service

What versions of Outlook and Exchange server are supported by the Starbucks for Outlook add-in?

The easiest way to know if you can use an Outlook add-in is by looking for the Add-ins "Store" button in the Home ribbon of your Outlook Inbox.

In order to use Outlook add-ins, you must be using a version of your Outlook client and Exchange server that supports add-ins. The table below lists all client and server versions that support Office add-ins.

Supported Clients

Supported Servers

· Outlook 2013 for Windows

· Outlook 2016 for Windows

· Outlook Web Access

· Outlook.com

· Outlook for Mac (Mail Read add-ins only)

· Office 365

· Outlook.com (only for accounts migrated to the new platform)

· Exchange 2013 (version 15.00.0516.032 or greater)

· Exchange 2016 (version 15.01.0225.042 or greater)

 

Find out which Exchange server version you are using by following these instructions.

Was this answer helpful?
Please tell us how we can make this answer more useful.
Note: Submissions will not receive a response. If you would like a response, go to our Contact Us page instead.